Network Platforms - High Latency to Asia and Australia 24 August 2025 – Incident details

High Latency to Asia and Australia 24 August 2025

Resolved
Degraded performance
Started 3 days agoLasted 2 days

Affected

IP Transit

Major outage from 2:39 PM to 11:37 AM

General Status IP Transit

Major outage from 2:39 PM to 11:37 AM

JB1 - PCCW AS3491

Major outage from 2:39 PM to 11:37 AM

Updates
  • Resolved
    Resolved

    Good day,

    Please kindly note that the latency has returned to normal. We are waiting for the provider to share the RFO.

    Kind regards,

    Network Platforms

  • Investigating
    Investigating

    Good day,

    We're experiencing high latency to some destinations in Asia and Australia.

    This issue has been escalated to the cable provider for further investigation.

    Current Observations:

    Johannesburg to Asia: Latency has increased to 259ms (normal baseline: ~116ms)

    Cape Town to Asia: Latency has risen to 277ms (normal baseline: ~215ms)


    We will share any significant updates as soon as they become available.

    Kind regards,

    Network Platforms