Network Platforms - High Latency to Asia and Australia 24 Oct 2025 – Incident details

High Latency to Asia and Australia 24 Oct 2025

Resolved
Degraded performance
Started about 19 hours agoLasted about 10 hours

Affected

IP Transit

Degraded performance from 2:07 AM to 12:08 PM

General Status IP Transit

Degraded performance from 2:07 AM to 12:08 PM

CT1 - PCCW AS3491

Degraded performance from 2:07 AM to 12:08 PM

JB1 - PCCW AS3491

Degraded performance from 2:07 AM to 12:08 PM

Updates
  • Resolved
    Resolved

    Good day,

    Please kindly note that the latency has returned to normal levels. We will share the RFO on the status page once it becomes available.

    Regards

    Network Platforms

  • Investigating
    Investigating

    Good Morning,

    We're experiencing high latency to some destinations in Asia and Australia.

    This issue has been escalated to the cable provider for further investigation.

    Current Observations:

    Johannesburg to Asia: Latency has increased to 176ms (normal baseline: ~116ms)

    Cape Town to Asia: Latency has risen to 259ms (normal baseline: ~135ms)


    We will share any significant updates as soon as they become available.

    Kind regards,

    Network Platforms