Network Platforms - Packet loss on international Long Distance 29 April 2025 – Incident details

Packet loss on international Long Distance 29 April 2025

Resolved
Degraded performance
Started 9 days agoLasted about 4 hours

Affected

International Long Distance

Degraded performance from 12:15 PM to 4:24 PM

Equano

Degraded performance from 12:15 PM to 4:24 PM

WACS

Degraded performance from 12:15 PM to 4:24 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Good day,

    We're experiencing packet loss on international Long Distance

    This issue has been escalated to the cable provider for further investigation.

    They are currently investigating this incident.

    They are seeing congestion between London to Lisbon. This is due to multiple 3rd party circuit outage in the area. They are working with their 3rd party provider to restores the circuits in a timely manner. We do not have an ETR at this time

    Kind regards,

    Network Platforms.