Network Platforms - Mail Delivery Issue – cPanel Hosting Platform – Incident details

Mail Delivery Issue – cPanel Hosting Platform

Resolved
Partial outage 30 %
Started about 4 hours agoLasted about 3 hours

Affected

Web Hosting

Partial outage from 7:53 AM to 8:16 AM, Operational from 8:16 AM to 8:16 AM, Partial outage from 8:16 AM to 10:44 AM

cPanel Web Servers

Partial outage from 7:53 AM to 8:16 AM, Operational from 8:16 AM to 8:16 AM, Partial outage from 8:16 AM to 10:44 AM

Updates
  • Resolved
    Resolved

    Good day

    The mail flow issue affecting our cPanel hosting platform has been fully resolved.

    Our engineers identified a corrupted firewall configuration as the root cause. After reconfiguring the firewall, all mail services have been successfully restored.

    Thank you for your patience and understanding during this time.

    Regards

    Network Platforms

  • Update
    Update
    Email delivery should now be functioning as expected. A temporary workaround has been applied to restore mail flow. Please note that the underlying issue has not yet been fully resolved. Our engineers are continuing to work on implementing a permanent solution. We will keep you updated on any further progress. Thank you for your continued patience.
  • Identified
    Identified

    Email delivery should now be functioning as expected. A temporary workaround has been applied to restore mail flow.

    Please note that the underlying issue has not yet been fully resolved. Our engineers are continuing to work on implementing a permanent solution.

    We will keep you updated on any further progress. Thank you for your continued patience.

  • Investigating
    Investigating

    We are aware of a mail delivery issue currently affecting our cPanel hosting platform. Our engineers are actively troubleshooting the problem and working to restore full service as quickly as possible.

    We will provide updates as soon as more information becomes available. We appreciate your patience and understanding.