Network Platforms - High Latency to Asia and Australia 18 Sept 2025 – Incident details

Experiencing partially degraded performance

High Latency to Asia and Australia 18 Sept 2025

Resolved
Degraded performance
Started about 1 month agoLasted about 11 hours

Affected

IP Transit

Degraded performance from 4:05 PM to 2:52 AM

General Status IP Transit

Degraded performance from 4:05 PM to 2:52 AM

JB1 - PCCW AS3491

Degraded performance from 4:05 PM to 2:52 AM

Updates
  • Update
    Update

    Good day

    Please see below the incident details of the increased latency to Asia and Australia experienced on the 18th of September 2025 between 6pm and 8pm.

    Outage Start Date / Time: 16:04 GMT on Sep 18
    Outage Resolve Date / Time: 19:53 GMT on Sep 18
    Reason of Outage: There was a transmission problem between Singapore and Johannesburg segment causing traffic to re-route via alternative path resulting in higher latency. 
    Resolution: Normal latency resumed after transmission problem is restored. 

    Regards

    Network Platforms

  • Resolved
    Resolved

    Good day

    Latency to Asia and Australia has returned to normal. We are yet to receive an incident report from the provider.

    Regards

    Network Platforms

  • Investigating
    Investigating

    Good day,

    We're experiencing higher than normal latency to destinations in Asia and Australia.

    This issue has been escalated to the cable provider for further investigation.

    Kind regards,

    Network Platforms